
Exercício 2 – versão QGIS 3.x 

Parte I 

Usar os mesmos arquivos de dados da aula anterior. 

Serão realizadas consultas por: 

• valor(es) de atributo(s) em uma camada; 

• relação espacial entre objetos de camadas distintas. 

Os atributos das instâncias selecionadas serão exportados como Tabela em arquivo 
formato texto. Também na forma camada de informação espacial (Tema, Plano ou 
Camada, conforme o software usado). 

Após abrir o QGIS, selecionar Project > New para começar um novo projeto. 
 

Sistema de coordenadas 

É sabido do exercício anterior que o sistema de coordenadas dos arquivos é o datum: 
SAD69 e projeção: UTM zone 23S. 

Selecione Project > Properties > CRS 

Na lista busque: SAD69(96) / UTM zone 23S EPSG:5533 

Clique em: [Apply] e depois feche a janela com: [OK] 

Verifique que a barra de status, na sua extremidade direita esteja indicando 
EPSG: 5533. 

Salve o projeto, dando lhe um nome conveniente, após verificar o local de sua 
criação (que deve ser na mesma pasta ou próxima dos arquivos de dados). 
 

Carregar os dados: 

1 Distritos: a partir de Districts.MIF(/MID) 

Selecione Layer > Add Layer > Add Vector Layer 

- Opção: (•) File 
- Encoding: windows-1252 
- Source: clique no botão […] para buscar o arquivo dos distritos: 
 navegue até e selecione Districts.MIF 
- clique no botão [Add] 

O QGIS carrega arquivos no formato << MIF/MID >> mas não processa esses dados 
com eficiência ou mesmo eficácia. O melhor a fazer é convertê-los para shapefile 
<< SHP/SHX/DBF/PRJ >> etc. 



Mas, antes verifique se o Encoding, codificação para caracteres selecionada, foi a 
correta: 


 Districts > Open Attribute Table 

O texto da coluna DENO está sem acentuação alguma (funcionaria para 
qualquer as codificações usuais para idiomas ocidentais ainda que a escolha 
fosse errada) e as demais colunas são numéricas, portanto nada a fazer. 

 Districts > Export > Save Features as... 

- Format: ESRI Shapefile 
- File name: clique no botão [...], navegue até a pasta desejada e dê um nome 
conveniente ao arquivo dos distritos, por exemplo, Distritos 
- CRS: selecione o recém definido: EPSG: 5533 – SAD69(96) / UTM zone 23S 
- Encoding: Windows-1252 
- selecione: [√] Add saved file to map para passar a trabalhar com os dados 
convertidos para shapefile 
Clique no botão [OK] para converter os dados e carregá-los no mapa 

Remova o layer anterior, em formato MIF/MID com  Districts > Remove Layer  
e 

Salve o projeto 

Observe o diagrama da Figura 1. 

Os arquivos MIF/MID que contém os dados geométricos e de localização espacial dos 
distritos, e de seus atributos, são lidos no ambiente do QGis, doravante representado 
como espaço-relacional, ou seja, layer + tabela de dados. A conexão entre a parte 
espacial (no layer) e a correspondente parte não espacial (na tabela), para cada ente 
de expressão espacial é representada pela linha de setas (bidirecional) abertas. 

O layer dos distritos tem a ele associado um símbolo, indicativo de se tratar de 
polígonos adjacentes. Esse símbolo é denominado ‘estereótipo’. 

A operação de leitura de um arquivo para o ambiente do QGis, no caso, na versão em 
inglês, está representada na forma de um retângulo com duas linhas verticais, cada 
uma próxima de um de seus lados. O fluxo de dados, lidos dos arquivos MIF/MID para 
o ambiente do QGis é representado por linhas com setas cheias. 

O layer + tabela, visível no ambiente do QGis, mantém um vínculo com os arquivos 
MIF/MID, o que significa que, alterações feitas dentro, ou fora, do ambiente do QGis 
são refletidas em ambos. Tal vínculo está sendo representado por uma linha de setas 
duplas abertas. 

 
1 Legenda:  indica seleção com o botão direito do mouse 



Uma segunda operação de geoprocessamento, no ambiente do QGis, converte os 
arquivos, do formato MIF/MID (MapInfo Interchange) para ESRI shapefile, no caso, 
composto por quatro arquivos (SHP, SHX, DBF e PRJ). 

Figura 1 – Leitura do layer Districts em formato MIF/MID e gravação em shapefile 

 

2 Estações do Metrô: do arquivo Subway_stations.SHP(/SHX/DBF) 

O ideal é que um diagrama indicativo de operações de geoprocessamento, como o 
da Figura 1, seja elaborado antes das operações serem executadas no software 
SIG. A Figura 2 indica operação similar no caso das estações do Metrô. 

No shapefile Subway_stations falta o arquivo PRJ, que indica o sistema de 
coordenadas usado. Sabe-se que se trata da projeção UTM 23 sobre o Datum 
SAD 69. 

Após adicionar o shapefile no ambiente do QGis com a operação Add Layer, faz-se 
a alteração do sistema de coordenadas, do default dado pelo QGis, para o correto. 
O fluxo de dados é representado por linha de seta cheia, em ambos lados, pois a 
informação do sistema de coordenadas é, primeiro, lida, para depois ter seu valor 
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alterado. A seta de leitura é opcional, pois o que interessa, neste caso, é a 
alteração dessa informação. Observar que esta operação, não gera o arquivo PRJ, 
por isso o layer deve ser exportado para um novo shapefile, no caso, MetroSP. 

No mais, o diagrama se assemelha ao do caso dos distritos. O layer das estações 
tem como estereótipo o ponto, ou seja, cada estação está sendo representada por 
um par de coordenadas no sistema indicado. 

Figura 2 - Leitura do layer Subway_stations e gravação como MetroSP, com a inclusão 
do sistema de coordenadas 

 

Selecione Layer > Add Layer > Add Vector Layer 

- Opção: (•) File 
- Encoding: windows-1252 
- Source: clique no botão […] para buscar o arquivo dos distritos: 
 navegue até e selecione Subway_stations.SHP 
- clique no botão [Add] 
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Por não existir o arquivo Subway_stations.PRJ o QGIS assume um default, 
possivelmente o EPSG:4326 – WGS84 - Geographic, e avisa para que se faça a 
associação correta. Caso em que obviamente os dados carregados não são exibidos 
na tela, por estarem referenciados ao sistema errado. 

O SRC atribuído às estações do Metrô pode ser visualizado em 
 Subway_stations > Properties > Information 

Para acertar o sistema de coordenadas selecione  
 Subway_stations > Properties > Source 

Altere para o EPSG: 5533 – SAD69(96) / UTM zone 23S 
e antes de clicar nos botões [Apply] e [OK], observe que existe um botão [Create 
Spatial Index] logo abaixo da seleção do sistema de coordenadas. 

Após a correção do sistema de coordenadas, observe que as estações do Metrô 
aparecem sobrepostas aos distritos no mapa, se na lista de Layers à direita da tela 
do mapa o layer Subway_sations estiver selecionado e acima do layer Distritos. 

Se navegar pelo browser de arquivos do Windows até a(s) pasta(s) nos quais os 
arquivos em uso estão gravados verifica-se que, no conjunto de arquivos shapefile 
dos distritos, há um Distritos com a terminação: .prj, a qual indica seu sistema de 
coordenadas estar definido. O mesmo não ocorre com os do Metrô. 

Aproveite para observar a existência do arquivo do projeto com o nome dado e 
com a terminação: .qgz. 

O melhor é criar tal arquivo, pois, apesar de estar corretamente referenciado no 
mapa da tela, e no projeto se este for salvo, muitas operações do QGIS acessam 
diretamente os arquivos físicos e podem se atrapalhar pela indefinição do sistema 
de coordenadas. 

Da mesma forma que feito, anteriormente, salve o 
Subway_stations.SHP(/SHX/DBF) para o mesmo formato, mas com outro nome, 
por exemplo, MetroSP, tendo o cuidado de verificar que o sistema de coordenadas 
seja o EPSG: 5533 – SAD69(96) / UTM zone 23S. 

Remova o layer anterior, com  Subway_stations > Remove Layer  
e 

Salve o projeto 

Verifique na pasta onde os novos arquivos foram gravados a existência do arquivo 
MetroSP.prj. 

3 Repita o procedimento acima para as estações da CPTM: do arquivo 
Railway_stations_pt.shp(/shx/dbf) 

Salve o projeto com um novo shapefile CPTM.shp(/shx/dbf/prj), inclusive com a 
indicação do sistema de coordenadas, a partir do conjunto Railway_stations_pt. 



4 Aproveite para criar indexação espacial nos distritos 

 Distritos > Properties > Source 
clique no botão [Create Spatial Index] 

A finalidade de se criar indexação espacial é de tornar as operações que envolvam 
a seleção espacial mais rápidas. No QGIS, a indexação espacial é fundamental. 

Verifique na pasta onde os distritos estão gravados, o arquivo Distrito, com a 
terminação: .qix. 

Parte II 

A Figura 3 indica as operações a serem feitas a seguir: (1) corresponde a agregação de 
dados da tabela de dados dos distritos, para se saber os máximos e mínimos para os 
dados mortalidade infantil e de população em favela do conjunto dos distritos; (2) 
seleção (por atributo) dos distritos sem favela; e (3) exportação dos dados dos distritos 
selecionados em (2) para um arquivo externo. 

Figura 3 – Operações de consulta, seleção por valor de atributo e exportação de tabela 

 

A operação de agregação dos dados da tabela (1) usa a notação da álgebra 
relacional. Aliás, esses diagramas são inspirados nas árvores de expressões, uma 
forma de notação da álgebra relacional. A operação seguinte (2) é de seleção por 
atributo. O fluxo dos dados lidos é representado pela seta cheia, enquanto que o 

apontamento dos distritos que satisfazem o predicado da seleção σ, é 

representado por seta aberta. Os processos indicados na Figura 3 não estão 
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representados como nos diagramas das figuras anteriores – estão sem as linhas 
verticais, por serem genéricos, e não específicos do software SIG usado. 

Analisar a tabela dos distritos – quais os máximos e mínimos para os dados 
mortalidade infantil MORT_INFAN e de população em favela POP_FAVELA ? (1) 

selecione Distritos 

Clique no ícone [ ∑ ] - Show Statistical Summary do menu superior, para visualizar 

estatística básica sobre seus atributos ou colunas da tabela de dados associada ao 
mapa. Na lista que se abre à esquerda do mapa, selecione os atributos 

MORT_INFAN 

Count: 96 ... Mínimum: 8 ... Maximum: 59 ... 

POP_FAVELA 

Count: 96 ... Minimum: 0 ... Maximum: 76.8 ... 

 

Selecionar os distritos com população em favela (2) 

 Distritos > Open Attribute Table 

Clique no ícone [ ε[  ] ] do menu superior da tabela de dados para abrir a caixa Select 

by Expression 

Na caixa de texto da esquerda, a partir da lista: Fields and Values > 
POP_FAVELA, com dois cliques do mouse 

 “POP_FAVELA” 

Selecione o operador > (maior do que) da lista Operators, com dois cliques do 

mouse, tendo antes o cuidado de verificar que o símbolo do operador > virá 

após a indicação do atributo POP_FAVELA 

 “POP_FAVELA” > 

Digite 0  (número zero) após o operador 

 “POP_FAVELA” > 0 

Clique no botão [ε[  ]  Select Features] para selecionar os distritos sem 

população favelada 

Feche ou minimize as caixas de diálogo Select by Expression e da tabela de atributos 
para Visualizar no mapa os distritos selecionados. 

Exportar tabela dos distritos com população em favela (3) 

Para não copiar os dados geométricos dos distritos selecionados, ou seja, as 
coordenadas dos vértices de seus polígonos, selecione o menu superior Settings > 
Options > Data Sources 

Em Feature attributes and tables > Copy feature as 
selecione a opção: Plain text, no geometry 



não esqueça de clicar no botão [OK] antes de fechar a janela, para a alteração 
ter efeito 

 Distritos > Open Attribute Table 

Altere a opção de visualização de [Show All Features] para [Show Selected Featrures], 
de modo a visualizar apenas os distritos que satisfazem o critério da consulta 

Clique no botão [   ] - Copy Selected Rows to Clipboard (Ctrl-C) 

Abra o aplicativo desejado, por exemplo, planilha eletrônica ou bloco de notas* 
e cole o conteúdo que acaba de copiar 

*Notas: 
- no caso de planilha eletrônica, cole especial como texto e, se necessário, acerte o 
formato dos números pela troca do ponto decimal por vírgula; 

- no caso de bloco denotas, a separação entre as colunas é feita, linha a linha com o 
uso do caracter especial Tab 
O bloco de notas permite que se copie o Tab, isto é, pela seleção e cópia,da região 
toda entre duas colunas numa mesma linha e se use esse caracter “fantasma” em 
operação de Editar > Substituir... (Edit > Replace...) colando-se o que foi copiado no 
campo a substituir e usando, por exemplo, o separador de ponto e vírgula para 
substituí-lo; 
Pode-se também trocar o ponto decimal dos números por vírgula para facilitar a 
leitura dos dados em outros programas; 
Tal opção gera um arquivo que pode ser salvo como CSV. 

Desfazer seleção 

Ainda na tela da Tabela de atributos, clique no ícone [   ] – Deselect All  

A lista de distritos aparenta estar vazia – pode-se alterar a opção de visualização de 
[Show Selected Featrures] para [Show All Features] para visualizar novamente os dados 
de todos os distritos. 

Visualizar o mapa – observar que não haja distritos selecionados. 



Parte III 

A Figura 4 indica as operações a serem feitas a seguir: (4.1) seleção (espacial) dos 
distritos com estação(ões) do Metrô em seu território; (4.2) seleção (espacial) 
adicional dos distritos que possuem estação(ões) da CPTM em seu território; (4.3) criar 
novo layer para esses distritos (com alguma estação); e (4.4) criar layer para os 
distritos sem estação alguma. 

Figura 4 – Operações de seleção espacial com criação de novos layers 

 

A operação 4.2 agrega eventuais distritos com estações da CPTM, mas sem estações 
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Selecionar os distritos com estações do Metrô em seu território (4.1) 

Trata-se de consulta espacial 

Sua seleção na interface do QGIS, assim como outras ferramentas, pode variar de 
versão para versão. 

No menu superior selecione: Vector > Research Tools > Select by Location 

Preencha os campos: 

Select features from: Distritos [EPSG:5533] 
where the features (geometric predicate) 
 [√] contain 
By comparing to the features from: MetroSP [EPSG:5533] 
Modify current selection by: creating new selection 

Execute a consulta especial pelo botão [ Run ] 

Ela será rápida se os Distritos tiverem sido previamente indexados espacialmente. 

Apenas minimize a janela Select by Location para visualizar o mapa e observar distritos 
selecionados – com estações do Metrô em seus territórios. 

Selecionar também os distritos com estações da CPTM em seu território (4.2) 

Proceda de forma semelhante com relação às estações da CPTM, mas com o cuidado 
de indicar que se deseja acrescer novos distritos aos já selecionados: 

… 
By comparing to the features from: CPTM [EPSG:5533] 
Modify current selection by: adding to current selection 

Execute novamente a consulta com [ Run ] 

Feche a janela Select by Location para visualizar o mapa e observar distritos 
selecionados – com estações do Metrô e da CPTM. 

Criar Layer com os distritos que contenham estações do Metrô ou da CPTM (4.3) 

Similar ao que foi feito quando se criou o shapefile Distrito, a partir Districts em 
MIF/MID, apenas indicar que sejam exportados os distritos selecionados. 

Criar seleção com os distritos que não contém estações do Metrô ou da CPTM (4.4) 
(Aproveitar os distritos selecionados para gerar o conjunto inverso) 

No menu superior há um grupo de ícones: 
 Select Features by Value... 
 Select features by Expression... 
 Select All Features 
 Invert Feature Selection 

O último inverte a seleção os distritos com estações do Metrô ou da CPTM em seu 
território, para distritos sem estações do Metrô ou da CPTM em seu território. 

O resultado no mapa é imediato. 


